Troubleshooting Going Live Issues in Streamlabs OBS

First, try the following:

  • Install Microsoft C++ Redistributables for 2017 and restart your PC after you do.
  • Log out from Streamlabs OBS, restart the application as an administrator and log back in.
  • Double-check your stream key if this is still correct.
  • If using Advanced Output Mode and using NVENC/AMD make sure GPU is set to "0".
  • If signed into Streamlabs OBS with Twitch - run the auto-optimizer found in General Settings
  • Please make sure you have 2FA enabled on your Twitch account.


If above did not work and or if you get the following error: Invalid Path or Connection URL. Please check your settings to confirm that they are valid.

  1. Go to Settings > Advanced and scroll down to the Bind to IP option.
  2. Change it from Default to your local machines. It should begin with 192.168.x.x or 10.0.x.x. (or another combination of numbers).
  3. Try to go live again.

If above did not work and or if you get an error

  1. Go to Stream in Settings
  2. Select a different service than you want to use.
  3. Select the streaming service you want to use again (this reloads the available servers).
  4. Select the server you want to use (do not use auto)
  5. Try going live again.

There are two ways you can go Live to YouTube from Streamlabs OBS:

  1. • Login to Streamlabs OBS with your YouTube account.
    • Press “Go Live” in Streamlabs OBS at the bottom right. A new event is automatically created.
  2. • Create a new event on the YouTube dashboard (new Dashboard).
    • Click “Go Live” in Streamlabs OBS.
    • Choose the created event from the drop-down section in the Go Live window.
    • Press “Confirm & Go Live”.

If you click Go Live and then click Confirm & Go Live but you get no error:

This is only for NVENC, you can check to see if you are using NVENC or NVENC (new) in Settings > Output

  1. Open Geforce Experience, click Drivers.
  2. Then click the 3 dots next to the driver if it's up-to-date, then click reinstall driver, if it's not up-to-date, click Download.
  3. Wait for it to download then click Custom Installation and check the box for Perform Clean Install when prompted, it will be on the bottom left of the custom install window.
  4. Continue to install and let it run.
  5. Once finished, try to go live with NVENC or NVENC (new).

**For AMD, OBS Project has a solution on their forums that could help you resolve this issue but if you choose to do so it is at your own risk.

If you are still having issues going live you could may need to clear your cache data. **PLEASE CONTACT A SUPPORT REPRESENTATIVE PRIOR TO CLEARING YOUR CACHE**

Have more questions? Submit a request

0 Comments

Article is closed for comments.